Author Topic: no output paths found after successful render. File not saved.  (Read 19566 times)

heolson

  • Jr. Member
  • **
  • Posts: 2
    • vimeo.com/hannaheolson
Hey everyone! I keep getting this most unfortunate problem whereby qube goes through the whole process of rendering and then cannot find the output file and just keeps going, telling me frames are completed when they never saved out anywhere. I'm rendering a Maya scene files with Vray, using Qube's Maya Batch Render->Vray. I verified that the specified render directory existed. I also attempted tests with the image name specified as well as tests where it was left blank so that Maya's name could be used and they both ran the same error. Here's a portion of my Stdout Log that specifies that there are no output paths found, but if you look in the paragraph above it you'll see that -rd is in fact pointing to a folder. Any help as to where I went wrong would be greatly appreciated! Thanks
Hannah

got work: 2888:105-109 - running
[Apr 13, 2013 16:20:30] ANM-CA301-PC02[6584]: work[2888:105-109] auto-retry[2]
[Apr 13, 2013 16:20:30] ANM-CA301-PC02[6584]: INFO: informing worker[127.0.0.1]
INFO: running frame 105-109 -
INFO: running cmd: "C:/Program Files/Autodesk/Maya2013/bin/Render.exe" -s 105 -e 109 -b 1 -rd "O:\03_PostProduction\Plates\Act_2\A2_S019_Phosphorus\Images" -proj "O:\02_Production" -renderer "vray" -log "O:\03_PostProduction\Plates\Act_2\A2_S019_Phosphorus\renderLog1_v001"  "O:\02_Production\scenes\05_Animation\ActII\S020_Phosphorus\S020_Phosphorus_v6_render_sphere.mb"
COMMAND: "C:\Windows\system32\cmd.exe" /C ""C:/Program Files/Autodesk/Maya2013/bin/Render.exe" -s 105 -e 109 -b 1 -rd "O:\03_PostProduction\Plates\Act_2\A2_S019_Phosphorus\Images" -proj "O:\02_Production" -renderer "vray" -log "O:\03_PostProduction\Plates\Act_2\A2_S019_Phosphorus\renderLog1_v001"  "O:\02_Production\scenes\05_Animation\ActII\S020_Phosphorus\S020_Phosphorus_v6_render_sphere.mb""
ender_sphere.mb""

INFO: execution successful.
-------------------------
SUMMARY of OUTPUT_PATHS:
No output paths found.
-------------------------
SUMMARY of HIGHLIGHTS:
No highlights found.
-------------------------
SUMMARY of ERRORS:
No errors found.
Hannah Olson
hannahemilyolson@gmail.com
vimeo.com/hannaheolson

jburk

  • Administrator
  • *****
  • Posts: 493
Re: no output paths found after successful render. File not saved.
« Reply #1 on: April 15, 2013, 04:57:49 AM »
The "No output paths found" message indicates that Qube can't find an image path in the data written to either the stdout or stder logs; it doesn't necessarily mean that your job failed to render a frame to disk, just that the job's output doesn't give Qube a clue where that frame is (or should be).

This job looks like it was submitted with the "Maya BatchRender V-Ray" submission UI; batchrender jobs often don't include the frame's output path in the job logs. 

Are there any rendered frames in the -rd directory?  Are you perhaps rendering out to the V-Ray frame buffer, but your renderGlobals are not set to also write a frame to disk as well?

Do you also have Qube's "maya" jobtype installed on your workers as well?  This jobtype (which is a separate, but very small, install) does require the Perl be installed on your workers in order for the jobtype to run, but the logging is much more informative and the render workflow is much more efficient than the batch renders.  You can submit a "maya" jobtype from inside Maya with Maya-->Qube-->Submit Render Job.  If you have this jobtype installed on your workers, I'd recommend you try it out.

heolson

  • Jr. Member
  • **
  • Posts: 2
    • vimeo.com/hannaheolson
Re: no output paths found after successful render. File not saved.
« Reply #2 on: April 15, 2013, 09:57:15 PM »
Hey, so I was able to check a couple of the things you asked about. One, no, there aren't any frames in the -rd. That's what originally made me aware of the problem. Also, Use Vray Frame buffer is not checked, so that's not the issue. Also, when I tried to install the Qube App UI into Maya it said that it Installed it but nothing showed up in Maya, even after closing and reopening twice. I tried running a test with the regular Submit Maya Job button in the regular Qube GUI, but Vray wasn't an option. What's a good workflow for submitting a Vray Job not using the Maya Batch thing but the other method you mentioned?Thanks!
Hannah
PS, I've attached the actual job logs

[attachment deleted by admin]
Hannah Olson
hannahemilyolson@gmail.com
vimeo.com/hannaheolson

rhagen

  • Full Member
  • ***
  • Posts: 18
Re: no output paths found after successful render. File not saved.
« Reply #3 on: May 10, 2013, 05:31:15 PM »
I usually just submit Vray jobs using the Maya Job Submit - this asks Qube to default to whatever the scene file says the renderer should be. Usually works. I always have my users specify the render output directory in the job submit even if they have it set in the project file... that way at least I know "this says the frames should have been put here" without having to dig through the Maya scene file.



I think Pipelinefx needs to make a specific Vray jobtype, though, and they should make a specific Vray Job Submit that is able to harness .vrscene files (the Maya job submit still needs Maya and the Maya Jobtype. I think there should be facility like there is with Mental Ray to have machines that only have the Vray Jobtype and Vray Standalone flags to render a .vrscene)

Not related to this but since I brought up Vray, Pipelinefx needs to make an Arnold Job Submit that uses KICK as well.