Author Topic: Configuration problem  (Read 3846 times)

Rich

  • Jr. Member
  • **
  • Posts: 5
Configuration problem
« on: April 17, 2007, 07:53:11 AM »
Greetings,
I am having 2 problems, (I think) 1 regarding my license and 1 regarding my worker.

When I run qbping on the supervisor I get --
supervisor - active - tag: 192.168.0.100 5.1-0 bld-5-1-2007-03-01-0 winnt - subjob - 0/2 licenses.

According to the email regarding my eval environment I should have 6 licenses for my supervisor and workers. 

When I run qbhosts on the supervisor I get --
total: 0/2 cpu(s)
name      macaddress         ipaddress      state  cpus  cluster  groups
RCSH2003  00:0C:76:EF:D5:E7  192.168.0.103  down   0/1   /       
rcsh2001  00:11:09:FC:37:A8  192.168.0.101  down   0/1   /       

I was trying to run a test job and it continues to say job is pending and workers are down.


On the host qubeworker is running and I can Ping the worker from the supervisor but qbping rcsh2001 reports --
unable to connect to host. worker - rcsh2001 - down.


I have read through the documentation as reviewed the forum but nothing has worked yet.

Thanks
r


anthony

  • Senior Software Engineer
  • Hero Member
  • *****
  • Posts: 183
Re: Configuration problem
« Reply #1 on: April 17, 2007, 08:16:27 AM »
Hey Rich,

     Sorry to hear about the configuration glitches you're having.  I'll break it down into 2 problems since they are each unrelated. 

     Normally, when we send out either an evaluation or a full license, it is contained as an attachment to the email.  Look for a qb.lic file.  If you have already gotten it, and have installed the file, but are unable to get the licenses to show (with qbping), these are the most common mistakes:

     #1.  License file accidentally installed as C:\windows\qb.lic.txt or C:\winnt\qb.lic.txt 
           Fix... to double check just goto "Start->Run" type notepad %SYSTEMROOT%\qb.lic if you do not have any text in there, you can now paste in the license which we sent to you which should look similar to this: (this license is broken for obvious reasons)

######################################################

[license_eval_0005]
licensee = "That's Some Company, Wilber"
vendor = "Pipeline FX L.L.C."
software = qube
assign_date = "May 30, 2004"
hosts = 10
exp_date = "Jun 29, 2004"
key = 3f115a94913de8b7c14e00a829f2cc7d

#######################################################

     #2.  The license file's permissions are unreadable.  You'll need to set the permissions to the file to be Readable by Everyone. 

     You're second problem is a little different.  From the look of things the worker's appear to be down in your hosts list.  This can happen if the machines are "powered-off" (well that one I put in there mostly cause I need to eliminate the obvious) or if you have firewalls turned on for either the supervisor or the worker's.  If you arn't connected directly to the internet without a firewall then you can probably get away with disabling the firewall on these machines completely.  However if that isn't an option, then your next best bet is to open up port 50011. If you don't know what I mean by opening up the port, then please try disabling the firewall first and we'll get into the more "sysadmin" type stuff later. 

     If you are still having trouble, (this part is for everyone reading this) please send us your logs.  You can post them, or portions of them to this forum or send them to support.  The most commonly useful ones are here:  C:\Program Files\pfx\qube\logs or for unix users including osx /var/log

     The files we are most interested in are: supelog.* and workerlog.*

     Please let us know if you are still having trouble. 

           Thanks,
                 Anthony

Pipeline FX - Support Engineer



Rich

  • Jr. Member
  • **
  • Posts: 5
Re: Configuration problem
« Reply #2 on: April 18, 2007, 03:13:28 AM »
Thanks Anthony,

I thought I had saved the qb.lic without the .txt but will double check that.  I had pasted in my license information from the email from Eric and will confirm I set the read permissions correctly.

The worker PC is on  :D but it's always good to ask.  I turned off the firewalls on the workers but now and not sure about the supervisor.  I will check that or try opening the port designated.  would an option be to build an exception to the firewall rules and allow Qube! to run?

I will try this out this evening and see how it goes.

thanks
r

Rich

  • Jr. Member
  • **
  • Posts: 5
Re: Configuration problem
« Reply #3 on: May 01, 2007, 03:55:14 AM »
Workers are still "down".  I can ping the worker from the supervisor and vice versa, BUT Qbping "worker name" times out and reports the worker as down.  Licenses are reported correctly and the file naming convention is correct.  I cannot take down the firewall but have allowed ports 50001 (tcp and udp) on the supervisor and 50011 (tcp and udp) on the workers.

eric

  • Hero Member
  • *****
  • Posts: 229
Re: Configuration problem
« Reply #4 on: May 04, 2007, 11:52:03 PM »
In order to make sure the Qube Supervisor and Worker can communicate, you will need to open up the following ports (TCP/UDP):

Supervisor
50001
50002
50003

Worker
50011