Author Topic: qbhosts returns 'active' status on unactive workers  (Read 2708 times)

neight

  • Jr. Member
  • **
  • Posts: 9
    • URI Pharmacy Animations
qbhosts returns 'active' status on unactive workers
« on: July 10, 2007, 03:40:43 PM »
when i do 'qbhosts' on the supervisor, it returns 2  machines as active...

machine 1 is powered off
machine 2 is unable to see the supervisor, or google.com.....

why?  ???

anthony

  • Senior Software Engineer
  • Hero Member
  • *****
  • Posts: 183
Re: qbhosts returns 'active' status on unactive workers
« Reply #1 on: July 10, 2007, 09:47:42 PM »
Hey Neight,

    The supervisor tries to conserve network traffic as much as possible by sending messages only when it is necessary.  The drawback to this is if a machine has been shutdown, the supervisor will not notice it for a period of time.  This however changes once the supervisor tries to send a job to the host.  It is then marked as unavailable.  The "active" state doesn't take any qube! licenses, so typically it's ok to just let the supervisor "think" the hosts are still active.  You can shorten the period of detection by setting up the workers and the supervisor to use a heartbeat check on each other.

    To enable it, turn on the "Heartbeat Monitor" in your Config gui under Supervisor Settings->Advanced Settings

    If you wish to tweak the timeout settings, then you'll need to edit the qb.conf file directly.  The default timeout before the supervisor checks on a host is 12 to 14 minutes.  You can tweak this by changing the following setting in this file:
     
  Windows            C:\winnt\qb.conf or C:\windows\qb.conf
  Linix/OSX           /etc/qb.conf

    supervisor_heartbeat_timeout = <number of seconds for timeout>
   
    You will need to restart the supervisor once these settings have been changed. 

     Thanks,
           Anthony