Author Topic: Qube gui crashes upon startup  (Read 4204 times)

arenyart

  • Full Member
  • ***
  • Posts: 23
Qube gui crashes upon startup
« on: October 23, 2007, 05:45:53 PM »
We recently had a blackout and my computer went down just as I was opening Qube gui.  After rebooting, the gui crashes everytime I try to open it.  It pops up a dialog box that says "Error occured" and tells me to "See the logfile ....qube.exe.log for details".  Here is the output to that logfile:

Traceback (most recent call last):
  File "qube.py", line 1300, in ?
  File "qube.py", line 1117, in __init__
  File "wx\_core.pyo", line 7749, in __init__
  File "wx\_core.pyo", line 7346, in _BootstrapApp
  File "qube.py", line 1130, in OnInit
  File "qbPrefs.pyo", line 306, in load
  File "pickle.pyo", line 1390, in load
  File "pickle.pyo", line 872, in load
KeyError: '\x00'


I tried reinstalling everything (twice) and it still does the same thing.  Any ideas?

Scot Brew

  • Hero Member
  • *****
  • Posts: 272
    • PipelineFX
Re: Qube gui crashes upon startup
« Reply #1 on: October 23, 2007, 05:56:57 PM »
It looks like your preferences file was corrupted when your machine went down.  After removing that file and you should be up and running again.  On Windows, the preferences file is located at:

C:\Documents and Settings\<user>\Application Data\qube\qube_guiPreferences.conf


arenyart

  • Full Member
  • ***
  • Posts: 23
Re: Qube gui crashes upon startup
« Reply #2 on: October 23, 2007, 06:12:40 PM »
Thanks.  That fixed it.

Scot Brew

  • Hero Member
  • *****
  • Posts: 272
    • PipelineFX
Re: Qube gui crashes upon startup
« Reply #3 on: November 27, 2007, 07:14:26 PM »
Glad to hear that handled it.