Author Topic: Python API - Mac OS X 10.5 Leopard  (Read 4593 times)

Mogga

  • Newbie
  • *
  • Posts: 1
Python API - Mac OS X 10.5 Leopard
« on: January 29, 2008, 11:22:51 PM »
Getting the following error on import of qb...

Code: [Select]
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/Library/Python/2.5/site-packages/PIL/__init__.py", line 28, in <module>
    
ImportError: dlopen(/Applications/pfx/qube/api/python/qb/_qb25.so, 2): Symbol not found: _environ
  Referenced from: /Applications/pfx/qube/api/python/qb/_qb25.so
  Expected in: flat namespace


Scot Brew

  • Hero Member
  • *****
  • Posts: 272
    • PipelineFX
Re: Python API - Mac OS X 10.5 Leopard
« Reply #1 on: January 30, 2008, 01:58:00 AM »
You have come across an incomatibility with python 2.5.0 and the 2.5.1 version that ships with Leopard. The upcoming Qube 5.3 will have direct support of the python 2.5.1 that ships with Leopard.

As an interim solution, you can download and use the python 2.5.0 from Active State under older versions (http://downloads.activestate.com/ActivePython/macosx/2.5/).  Newer versions may work as well but have not been tested.