Author Topic: Rendering using p_Megatk shader  (Read 6257 times)

jimmyt

  • Full Member
  • ***
  • Posts: 11
Rendering using p_Megatk shader
« on: March 11, 2008, 07:58:52 PM »
Hi -- I am rendering a test scene using this shader. I can miGen fine, but upon trying to render frames through Qube I get the following error:

Can't locate JobType.pm in @INC (@INC contains: /usr/local/pfx/jobtypes /usr/local/pfx/qube/types /usr/local/pfx/qube/api/perl/qb/blib/arch/auto/qb /usr/local/pfx/qube/api/perl /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7 /usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8 . /usr/local/pfx/qube/api/perl/58) at /usr/local/pfx/jobtypes/mentalray/MentalrayJob.pm line 7.
BEGIN failed--compilation aborted at /usr/local/pfx/jobtypes/mentalray/MentalrayJob.pm line 7.
Compilation failed in require at /usr/local/pfx/jobtypes/mentalray/execute.pm line 11.
BEGIN failed--compilation aborted at /usr/local/pfx/jobtypes/mentalray/execute.pm line 11.
Compilation failed in require at /var/spool/qube/job/0/707/707_0.pm line 10.

This feels Qube to me -- am I right? Has anyone had experience rendering with this shader?

Normal mental ray renders fine on the node. Any help would be appreciated.

j

eric

  • Hero Member
  • *****
  • Posts: 229
Re: Rendering using p_Megatk shader
« Reply #1 on: March 11, 2008, 08:19:27 PM »
You need to download and install JobTypeLib from the pub/jobtypes directory on our FTP server.

jimmyt

  • Full Member
  • ***
  • Posts: 11
Re: Rendering using p_Megatk shader
« Reply #2 on: March 11, 2008, 10:51:15 PM »
Thanks for the reply.

I have the folder -- our farm is linux and the supervisor and workstations are OSX. Should I be installing this on the local user machines, or on the supervisor?

j


jimmyt

  • Full Member
  • ***
  • Posts: 11
Re: Rendering using p_Megatk shader
« Reply #3 on: March 11, 2008, 10:59:09 PM »
BTW -- before I installed this custom shader, Qube was working fine with job submissions and renders. I have the jobtypes local folder, so am 95% sure this has already been installed.

I have inherited supporting this network from someone who didn't finish the job and didn't document what was installed where and when, so picking up the pieces and trying to figure out what I am supposed to do, basically from scratch...

j


eric

  • Hero Member
  • *****
  • Posts: 229
Re: Rendering using p_Megatk shader
« Reply #4 on: March 12, 2008, 12:00:02 AM »
Until you can get access to the FTP site, there isn't much you can do, unless you can find the previously downloaded installers. You'll need to install the Job Types and the JobTypeLib on the Workers.

jimmyt

  • Full Member
  • ***
  • Posts: 11
Re: Rendering using p_Megatk shader
« Reply #5 on: March 12, 2008, 01:07:13 AM »
I have ftp access. We already have the /jobtypes/ folder on the supervisor, the workstations and the workers. This was set up a little over a month ago so assuming all software is current.

Am I right in assuming that JobTypesLib installs this folder?

j


eric

  • Hero Member
  • *****
  • Posts: 229
Re: Rendering using p_Megatk shader
« Reply #6 on: March 12, 2008, 06:40:17 PM »
You are correct. It must be installed on each Worker in order for the Job Types to function.

jimmyt

  • Full Member
  • ***
  • Posts: 11
Re: Rendering using p_Megatk shader
« Reply #7 on: March 13, 2008, 12:20:39 AM »
./jobtypes folder is on the worker, in /usr/local/pfx/

I can render scenes in mental ray using the standard shader but the minute I try to use this custom shader I get this error. I could try and install another custom shader and see if I get the same problem, to see if this issue is unique to this shader and qube or custom shaders in general?

I am install the shader in the /usr/local/mi351/lib and /include folders, as well as the mentalray/include and /lib/ folders in /maya8.5/ on the worker.

Error in qube:

Can't locate JobType.pm in @INC (@INC contains: /usr/local/pfx/jobtypes /usr/local/pfx/qube/types /usr/local/pfx/qube/api/perl/qb/blib/arch/auto/qb /usr/local/pfx/qube/api/perl /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7 /usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8 . /usr/local/pfx/qube/api/perl/58) at /usr/local/pfx/jobtypes/mentalray/MentalrayJob.pm line 7.
BEGIN failed--compilation aborted at /usr/local/pfx/jobtypes/mentalray/MentalrayJob.pm line 7.
Compilation failed in require at /usr/local/pfx/jobtypes/mentalray/execute.pm line 11.
BEGIN failed--compilation aborted at /usr/local/pfx/jobtypes/mentalray/execute.pm line 11.
Compilation failed in require at /var/spool/qube/job/0/732/732_0.pm line 10.


eric

  • Hero Member
  • *****
  • Posts: 229
Re: Rendering using p_Megatk shader
« Reply #8 on: March 13, 2008, 12:29:30 AM »
This problem is caused by a missing JobTypeLib.
Installing it should solve the problem.

jimmyt

  • Full Member
  • ***
  • Posts: 11
Re: Rendering using p_Megatk shader
« Reply #9 on: March 13, 2008, 01:09:17 AM »
After I stopped arguing and just went and installed what you told me to install everything worked. I guess I shouldn't assumed that the folder being on the system implied that it was fully install!

Thanks for your help!

j