Author Topic: Python version conflict  (Read 5991 times)

laschmoove

  • Sr. Member
  • ****
  • Posts: 29
Python version conflict
« on: November 10, 2008, 09:30:28 PM »
Hi everybody,
I just like to hear if there's anybody using qube with XSI and Vista64, since I got a problem with python.

For XSI on Vista, I need Python 2.6 since there is no pywin for 64 bits that supports python 2.4. And qube needs python 2.4.

Is it possible to install both python versions? Or is there another workaround?

Thanks for helping,
laschmoove

eric

  • Hero Member
  • *****
  • Posts: 229
Re: Python version conflict
« Reply #1 on: November 10, 2008, 09:40:03 PM »
I believe you should be able to install both.

laschmoove

  • Sr. Member
  • ****
  • Posts: 29
Re: Python version conflict
« Reply #2 on: November 11, 2008, 02:03:45 PM »
Thank you for the fast reply, Eric.

Now I have both versions of python installed, but qube still seems to look for the version 2.6. This is waht I get:
Quote
ERROR : Traceback (most recent call last):
'   File "<Script Block >", line 14, in <module>
'     import qb
'   File "C:\Program Files\pfx\qube\api\python\qb\__init__.py", line 25, in <module>
'     exec('import '+qbPythonVer+' as _qb')
'   File "<string>", line 1, in <module>
' ImportError: No module named _qb26
'  - [line 14]
ERROR - Cannot parse script.
FATAL - Script Aborted.

Is there a way to tell qube to look for the _qb24.dll or _qb25.dll (which are available) instead of _qb26.dll?

Thanks again,
laschmoove

eric

  • Hero Member
  • *****
  • Posts: 229
Re: Python version conflict
« Reply #3 on: November 12, 2008, 06:58:00 AM »
Apologies for giving you inaccurate information. Unfortunately, when the XSI Job Type runs, XSI will try to execute our custom Python scripts. Those scripts require the 2.6 Qube API module, which we don't have at this time.

Under these circumstances, you'll need to submit XSI batch renders instead of Job Type renders.

laschmoove

  • Sr. Member
  • ****
  • Posts: 29
Re: Python version conflict
« Reply #4 on: November 12, 2008, 11:01:21 AM »
Hi Eric,
that's a pity! Do you know when you will support the latest python version?
It is very difficult to maintain several software packages where most of them require the latest version of python and one does not support it yet...

Thanks,
laschmoove



laschmoove

  • Sr. Member
  • ****
  • Posts: 29
Re: Python version conflict
« Reply #5 on: March 24, 2009, 07:47:33 PM »
Are there any news on this issue? Is there still no _qb26.dll?

An update would be very nice...

Best,
laschmoove

jesse

  • Sr. Member
  • ****
  • Posts: 40
Re: Python version conflict
« Reply #6 on: March 26, 2009, 12:54:10 AM »
Last I heard, PipelineFX is bound to the Active Python releases.  There is currently no 2.6 for windows x86_64.

Check out the downloads here:
http://downloads.activestate.com/ActivePython/windows/