Author Topic: Uninstalling qube for upgrade to 5.4 on linux  (Read 5418 times)

jbrandibas

  • Sr. Member
  • ****
  • Posts: 35
Uninstalling qube for upgrade to 5.4 on linux
« on: December 30, 2008, 09:44:15 PM »
Hello,

   I am running my supervisor node on a Linux box running Fedora core 3.  I am trying to do the upgrade from version 5.2 to 5.4.  Per the instructions I need to do rpm --erase --noscripts qube-core    and qube-supervisor.  The qube-supervisor removes correctly, however it tells me that qube-core does not exist.  If I try and install the qube-5.4-0-FC-3.i386.rpm it tells me that it conflicts with the currently installed package qube-5.2-1.  I then tried to remove that package, but I start getting dependency errors with other qube packages such as php.  I figure that I am heading into a downward spiral of package removal when all I need is the correct package to remove that will uninstall the 5.2 core correctly.

What do I need to do to remove the 5.2 core, or do I have to go through all of the dependencies manually?

siyuan.pipelinefx

  • Sr. Member
  • ****
  • Posts: 32
Re: Uninstalling qube for upgrade to 5.4 on linux
« Reply #1 on: December 30, 2008, 10:49:43 PM »
Try running the command "rpm -ev [package_name]" in this case the package_name is the name of the qube core package, something like "qube-5.2-1-fc...." if you're not sure what packages you had installed type in "rpm -qa qube\*" to find out.  What is the result?

jbrandibas

  • Sr. Member
  • ****
  • Posts: 35
Re: Uninstalling qube for upgrade to 5.4 on linux
« Reply #2 on: December 31, 2008, 12:08:17 AM »
I finally got it.  I had to remove those dependency packages and it finally let me remove the core.