Author Topic: environment not loading on workers  (Read 3285 times)

mrdebout

  • Jr. Member
  • **
  • Posts: 5
environment not loading on workers
« on: January 08, 2009, 04:55:14 PM »
Hello,

i searched the forum and scanned the documentation another time but i haven't found anything about that

My problem is that i've got some environment variables in qubeproxy's bashrc file but that they are left out when i'm running a job

I know that i can export environment variables when i submit a job, but that's not what i want. I just want the local env to be loaded, any ideas ?

Some troubleshooting data

* definition of the qubeproxy user in vipw
qubeproxy:x:1001:1001::/home/qubeproxy:/bin/bash

* permissions of the .bashrc file
-rw-r--r-- 1 qubeproxy qubeproxy 2514 2009-01-07 17:40 .bashrc

* excerpt from calling env in a term
$ env
SHELL=/bin/bash
USER=qubeproxy
DELIGHT=/usr/local/3delight
DL_SHADERS_PATH=/usr/local/3delight/shaders
PATH=/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/local/3delight/bin:/usr/local/pfx/qube/bin:/usr/local/pfx/qube/sbin
QUBECORE=/usr/local/pfx/qube

* excerpt from calling env during a job
SHELL=/bin/bash
USER=qubeproxy
QBPGRPID=12664
PATH=/usr/local/bin:/usr/bin:/bin:/usr/games


siyuan.pipelinefx

  • Sr. Member
  • ****
  • Posts: 32
Re: environment not loading on workers
« Reply #1 on: January 09, 2009, 04:07:50 AM »
Hello there. Use ".profile" file instead of ".bashrc".  It seems like the ".bashrc" file is sourced only when you're doing an interactive shell.

mrdebout

  • Jr. Member
  • **
  • Posts: 5
Re: environment not loading on workers
« Reply #2 on: January 09, 2009, 05:24:58 PM »
thanks a lot, it does work better