Author Topic: Would like to use qube.py but can<t find _qb25.so  (Read 5119 times)

francois

  • Jr. Member
  • **
  • Posts: 5
Would like to use qube.py but can<t find _qb25.so
« on: November 12, 2009, 10:29:06 PM »
We'd like to use qube.py instead of the executable version (in order to be able to customize it if the mood strikes us).

We're using python 2.5 on linux and windows. After installing pywin32, qube.py works fine on windows. On linux machines, he complains that _qb25 can't be found. When looking in the installation directory, I've notices that only _qb24.so has been installed.

Where can I find _qb25.so ?

Scot Brew

  • Hero Member
  • *****
  • Posts: 272
    • PipelineFX
Re: Would like to use qube.py but can<t find _qb25.so
« Reply #1 on: November 12, 2009, 11:24:14 PM »
Qube's python module is built on the default python version installed for the particular flavors and versions of Linux.  The flavor and version of Linux that you are using may be using a different python version than the Qube rpms installed.

The link attached contains a list of the qualified platforms for Qube.
    http://www.pipelinefx.com/products/technical-specs.php

Please note that there are a few new Linux platforms added for Qube 5.5 including OpenSuSE 11.1 x64, RHEL 5.3 x64, and Fedora 8 x64.

We'll follow up directly with you to see how we can further assist with your Linux installation.

« Last Edit: November 12, 2009, 11:26:21 PM by Scot Brew »

francois

  • Jr. Member
  • **
  • Posts: 5
Re: Would like to use qube.py but can<t find _qb25.so
« Reply #2 on: November 13, 2009, 12:04:21 AM »
Thanks for your answer, but we decided to use python 2.5 instead of the version that comes packaged with our version of linux (RHEL 5).
Windows version of qube comes with support for all flavors of python (at least from 2.3 to 2.5), why is it not the case on linux ?

shinya

  • Administrator
  • *****
  • Posts: 224
Re: Would like to use qube.py but can<t find _qb25.so
« Reply #3 on: November 13, 2009, 02:19:59 AM »
Hi francois,

We do support python 2.5 on the RHEL 5.2 x64, and RHEL 4 x64 platforms.

What is your specific RHEL version?


francois

  • Jr. Member
  • **
  • Posts: 5
Re: Would like to use qube.py but can<t find _qb25.so
« Reply #4 on: November 13, 2009, 08:45:47 PM »
I think it's 5.3.
We used the qube*-5.5-0-RHEL_Server-5.3-x86_64.x86_64.rpm packages, and they only contain _qb24.so .

shinya

  • Administrator
  • *****
  • Posts: 224
Re: Would like to use qube.py but can<t find _qb25.so
« Reply #5 on: November 13, 2009, 09:12:00 PM »
Hi Francois,

Okay, then we'll need to compile our python support code for python 2.5 (and maybe 2.6)
on RHEL 5.3.  That could take some time.  If you want to try the .so binary built for RHEL
5.2, let us know-- I can probably give that to you sooner, and it may just work.




francois

  • Jr. Member
  • **
  • Posts: 5
Re: Would like to use qube.py but can<t find _qb25.so
« Reply #6 on: November 13, 2009, 09:36:42 PM »
Yes, I would like to try the _qb25.so built for RHEL 5.2.

Thanks a lot !

shinya

  • Administrator
  • *****
  • Posts: 224
Re: Would like to use qube.py but can<t find _qb25.so
« Reply #7 on: November 13, 2009, 09:54:40 PM »
Hi Francois,

Ok, I will email you the download info shortly. Please watch your inbox!

-shinya.