Author Topic: worker cant find files...  (Read 2229 times)

max.kuzubov

  • Jr. Member
  • **
  • Posts: 2
worker cant find files...
« on: March 02, 2010, 02:01:53 PM »
Qube 5.5.1 + MentalRay 3.7.1 + Windows server HPC edition

i submit a job and have many errors. first error i see:

ERROR: file [//Dc-01/MI-Files/P01/Ep02/sc037/MI/P01_E02_sc037.0001.mi] does not exist on the execution host [RENDERNODE-01] at C:\Program Files\pfx\qube\api/perl/JobType.pm line 816.

when i copy .mi files to local c:\temp\ i see new errors:

INFO: running: "Z:\SAVVA\netplugins\mental3.7\render.bat"  -v 5 "c:/temp/P01_E02_sc037.0002.mi"
'"Z:\SAVVA\netplugins\mental3.7\render.bat"' is not recognized as an internal or external command,
operable program or batch file.


but if i runiing that string from cmd.exe - its worked!
why worker cant see network files and local .bat files?

on this computer i use deadline for render and all worked. its worked farm and all pathes and access setuped

jburk

  • Administrator
  • *****
  • Posts: 493
Re: worker cant find files...
« Reply #1 on: March 02, 2010, 03:34:35 PM »
The worker is unable to mount the network drives or access the shares via UNC.  Are you running the worker in service mode or desktop user mode?  And are you using a proxy user, and does that proxy user have permissions to mount or access network shares?

As a test, take a note of the drives you have mapped on your local workstation with the "net use" command.  Then submit a job to your farm that also runs "net use".  Compare the output of this command when run locally and on the worker.