Author Topic: qblogin (as administrator) not pulling in the "--user username" option  (Read 2672 times)

jordan

  • Jr. Member
  • **
  • Posts: 6
Hi,

When running qblogin as the administrator user (su administrator on a mac), qblogin doesn't appear to be recognizing the "--user username" option. Instead, it appears to be attempting to change the password for the administrator user:

{10:55}[administrator@mymac:/] $ qblogin --user testuser
Current User: administrator
Current Domain: mydomain
Windows password:


{10:55}[administrator@Farwest:/] $ qblogin --user modtest --check
Current User: administrator
Current Domain: rodeofx
password ok

jburk

  • Administrator
  • *****
  • Posts: 493
Re: qblogin (as administrator) not pulling in the "--user username" option
« Reply #1 on: August 18, 2010, 04:02:24 PM »
It actually is changing the password for the user specified with the --user flag.  I've verified this by checking the password stored in the Qube database; it does change for the user specified, not the user who ran qblogin.

I'll put in a bug report; it makes sense that it should show who it's changing the password for, not who's running it.

burk-17-mbpro:datawh jburk$ qblogin --user foobar
Current User: jburk
Current Domain: .
Windows password:
Retype password:
INFO: updated password.

jburk-17-mbpro:datawh jburk$ mysql -u root -e "select user,passwd from qube.passwd\G"
*************************** 1. row ***************************
  user: foobar
passwd: 11adfbdc1cc196eb82952d005e192cd9ff3ae7a9a5a492251558bce3403f0a2f

jburk-17-mbpro:datawh jburk$ qblogin --user foobar
Current User: jburk
Current Domain: .
Windows password:
Retype password:
INFO: updated password.

jburk-17-mbpro:datawh jburk$ mysql -u root -e "select user,passwd from qube.passwd\G"
*************************** 1. row ***************************
  user: foobar
passwd: 123ff105e8c5282d40688cf2aa6347aa3a1c1736a0925dd8f310e96cacb82560


jordan

  • Jr. Member
  • **
  • Posts: 6
Re: qblogin (as administrator) not pulling in the "--user username" option
« Reply #2 on: August 18, 2010, 04:37:59 PM »
Awesome...thanks for the help!
Jordan