Author Topic: jobs complete but show 100% complete and don't remove from gui  (Read 4043 times)

westernx

  • Hero Member
  • *****
  • Posts: 55
jobs complete but show 100% complete and don't remove from gui
« on: October 01, 2010, 06:00:02 PM »
Hello,

I have been having some weird issues with qube.  This seems to be pertaining to a specific user,  who is not able to kill, remove, modify etc. . there own jobs.  Also, this user's jobs hang in the gui,  showing 100% complete, showing a subjob running but the subjob is not actually running on the specified server.  The job will not kill, but if I do a qbremove as root, it finally removes from qube gui.

I've setup the user in the Admin Layout tab of qube gui,  with default permissions, however this does not seem to work.

Others have been complaining about not being able to modify, or kill there own jobs aswell.  Could this be corrupted qube databases? 

For the most part qube is doing it's job and jobs are completing successfully.

jburk

  • Administrator
  • *****
  • Posts: 484
Re: jobs complete but show 100% complete and don't remove from gui
« Reply #1 on: October 01, 2010, 06:35:38 PM »
Can you post the output from 'qbusers --list'?  And you might want to get the users into the habit of running QubeGUI->View->Refresh (clear cache) before they try to perform operations on jobs; quite often the QubeGUI can contain entries for jobs that no longer exist in Qube. 

This is due to the caching nature of the qubeGUI.  Version 5.5-3 and later of the GUI has a preference option that allows you to modify the behavior of the Refresh button so that it does the same thing as the "Refresh (clear cache)" menu item.

westernx

  • Hero Member
  • *****
  • Posts: 55
Re: jobs complete but show 100% complete and don't remove from gui
« Reply #2 on: October 01, 2010, 06:41:27 PM »
Output of qbusers --list on qube supervisor server ;

Code: [Select]
vfx-xserve:~ root# /Applications/pfx/qube/sbin/qbusers --list
total 10
as-l jc- krmpbuicseyqg-vft- [default]
asil jcg krmpbuicseyqgpvftn Administrator
---l jcg krmpbuicseyqg-vft- hchoi
asil jcg krmpbuicseyqgpvftn qube
asil jcg krmpbuicseyqgpvftn rletourneau
asil jcg krmpbuicseyqgpvftn root
asil jcg krmpbuicseyqgpvftn system
a--- --- ------------------ vfx05
a--- --- ------------------ vfx07
asil jcg krmpbuicseyqgpvftn vfx08
asil jcg krmpbuicseyqgpvftn vfx08.keystone

I guess I should download 5.5-3 gui and try it out . . .

westernx

  • Hero Member
  • *****
  • Posts: 55
Re: jobs complete but show 100% complete and don't remove from gui
« Reply #3 on: October 01, 2010, 06:42:36 PM »
 . . . the user I am having the issues with is   hchoi . . .

jburk

  • Administrator
  • *****
  • Posts: 484
Re: jobs complete but show 100% complete and don't remove from gui
« Reply #4 on: October 05, 2010, 03:08:45 PM »
I notice that you've given the 'admin' privilege to the default user, but not to hchoi.  This user will then be able to only delete their own jobs, while everyone else will be able to delete anyone else's.  Is this what you want?

Also, note that the names in the qbusers list are case-sensitive, although this doesn't really apply here, since if hchoi was logging as a HChoi, they'd be getting the default user permissions, which includes 'admin'...

Try removing the hchoi user from the qbusers list with

Code: [Select]
qbusers --drop hchoi
Then he'll have the admin privileges.  Then ensure that before he tries to modify any of his jobs, he does a QubeGUI->View->Refresh (clear cache) to update the joblist in the QubeGUI.

If you're running a version of the QubeGUI that's later than 5.5-2, there is also a option in the preferences, "Refresh Button clears cache", which will hook the Refresh button up to the "clear cache" behavior.