Author Topic: 3Ds Max Job - Can't locate qbboot.pm in @INC  (Read 1324 times)

modcoyote

  • Newbie
  • *
  • Posts: 1
3Ds Max Job - Can't locate qbboot.pm in @INC
« on: May 29, 2015, 08:33:45 AM »
Hi.

Today I installed Supervisor module and additional two Worker nodes for simple test.
After submiting job from 3Ds Max it goes almost instantly into "failed" status.
Of course Perl and Python are installed.
Can't figure out what's causing it.
 :-\

Qube! version: 6.7.0
3Ds Max 2015 (latest SP) + Vray 2.50.01
ActivePerl: 5.20.2.2001
ActivePython: 2.7.8.10

Error log:
Quote
Can't locate loadable object for module qb in @INC (@INC contains: C:\Program Files (x86)\pfx\jobtypes C:\Program Files\pfx\jobtypes C:\Program Files\pfx\qube\\types C:\Program Files\pfx\qube\api/perl/qb/blib/arch/auto/qb C:\Program Files\pfx\qube\api/perl C:/Perl64/site/lib C:/Perl64/lib .) at C:\Program Files\pfx\jobtypes/qbboot.pm line 0.
Compilation failed in require at C:\Program Files\pfx\qube\api/perl/qb.pm line 66.
BEGIN failed--compilation aborted at C:\Program Files\pfx\qube\api/perl/qb.pm line 66.
Compilation failed in require at C:\ProgramData\Pfx\Qube\logs\job\0\251\251_0.pm line 6.
BEGIN failed--compilation aborted at C:\ProgramData\Pfx\Qube\logs\job\0\251\251_0.pm line 6.
 6.
Can't locate qbboot.pm in @INC (you may need to install the qbboot module) (@INC contains: c:\Program Files\pfx\jobtypes c:\Program Files\pfx\qube\\types c:\Program Files\pfx\qube\api/perl/qb/blib/arch/auto/qb c:\Program Files\pfx\qube\api/perl C:/Perl64/site/lib C:/Perl64/lib .) at c:\Program Files\pfx\qube\api/perl/qb.pm line 66.
BEGIN failed--compilation aborted at c:\Program Files\pfx\qube\api/perl/qb.pm line 66.
Compilation failed in require at C:\ProgramData\Pfx\Qube\logs\job\0\251\251_1.pm line 6.
BEGIN failed--compilation aborted at C:\ProgramData\Pfx\Qube\logs\job\0\251\251_1.pm line 6.
6.

BrianK

  • Hero Member
  • *****
  • Posts: 107
Re: 3Ds Max Job - Can't locate qbboot.pm in @INC
« Reply #1 on: June 01, 2015, 05:30:20 PM »
Qube does not yet support Perl 5.20 on Windows ( as of June, 2015).

You'll need to install an older version of Perl (5.16 or older) to use Perl-based jobtypes.  You can still download Perl 5.16 from Strawberry Perl: http://strawberryperl.com/releases.html

We are working on upgrading our Perl integration & should have support for 5.20 in a near-term upcoming release.