Author Topic: python version needed for qube 5.4 and XSI 7.0  (Read 2933 times)

foureyes

  • Jr. Member
  • **
  • Posts: 9
python version needed for qube 5.4 and XSI 7.0
« on: August 28, 2008, 06:07:06 AM »
We are currently using qube 5.3 with Python 2.5.1.1 installed. Now we are upgrading our XSI to 7.0 and will also upgrade qube GUI to 5.4. When we install XSI 7.0, it says it cannot find python 2.4 installed. Therefore

1. Should we uninstall our Python 2.5.1.1 and reinstall Python 2.4?

2. We also have Maya 2008 and 3ds max 2008 in the rendering farm. We will soon upgrade them to Maya 2009 and 3ds max 2009. Will Python 2.4 also work with them?

3. What is the official version that qube 5.4 requires for Perl and Python?

4. Will qube also provide the download link for the most compatible version of Perl and Python?

Thanks.


eric

  • Hero Member
  • *****
  • Posts: 229
Re: python version needed for qube 5.4 and XSI 7.0
« Reply #1 on: August 29, 2008, 12:06:51 AM »
Quote
We are currently using qube 5.3 with Python 2.5.1.1 installed. Now we are upgrading our XSI to 7.0 and will also upgrade qube GUI to 5.4. When we install XSI 7.0, it says it cannot find python 2.4 installed. Therefore

1. Should we uninstall our Python 2.5.1.1 and reinstall Python 2.4?

Not necessarily. You should consult with Softimage on the correct versions of Python you need, but should be able to install both 2.4 and 2.5.

Quote
2. We also have Maya 2008 and 3ds max 2008 in the rendering farm. We will soon upgrade them to Maya 2009 and 3ds max 2009. Will Python 2.4 also work with them?

We are currently in testing for Max and Maya 2009. In the meantime, they may work with Qube, but they are not supported.

Quote
3. What is the official version that qube 5.4 requires for Perl and Python?

Perl 2.4
Python 5.8

Quote
4. Will qube also provide the download link for the most compatible version of Perl and Python?

You can find information on where to download compatible versions of Perl and Python in our Installation Documentation. We recommend ActiveState for Windows. All other supported platforms should have the proper Python already installed.