Author Topic: FIFO scheduling not working as expected  (Read 3105 times)

dh

  • Jr. Member
  • **
  • Posts: 6
FIFO scheduling not working as expected
« on: October 02, 2008, 05:33:39 PM »
Hi,

I'm having problems understanding the way Qube prioritizes/schedules jobs. In our setup, all jobs have the same priority, and we're not using any clusters (i.e., everything is in cluster '/'). As well, I've got the supervisor's "supervisor_queue_library" set to "queue".

Based on all of this, I would expect that jobs that are submitted first would be processed first, but that's not what seems to be happening. Instead, it seems like Qube is giving priority to jobs that have been recently submitted.

The one potential problem I can see in all of this is that our jobs are submitted in groups of for, with a dependency chain between them (i.e., for jobs A, B, C, and D -- B and C wait for A to complete before running, and then D waits for B and C to complete before running).

Is it possible that jobs with dependency-chains (i.e., one job waits for a 'completed' callback from another job before unblocking itself) don't play well with the FIFO scheme? Does FIFO look at when a job was unblocked to determine the time the job 'entered' the queue? If so, can I work around that somehow?

Any help would be greatly appreciated!

Thanks in advance,
-dh

shinya

  • Administrator
  • *****
  • Posts: 230
Re: FIFO scheduling not working as expected
« Reply #1 on: October 04, 2008, 04:04:28 AM »
Hi dh,

As we've asked through the support email case, please send us the logs for analysis.

Thanks!

-shinya.

eric

  • Hero Member
  • *****
  • Posts: 229
Re: FIFO scheduling not working as expected
« Reply #2 on: October 21, 2008, 08:48:41 PM »
You could also try this:
  • Login to your Supervisor
  • Open the Configuration GUI
  • Go to the Supervisor Settings Tab
  • Go to the Advanced Settings Tab
  • Uncheck the box label "Disable First Come First Serve"
  • Click OK to save settings and restart the Supervisor