Author Topic: qbwrk.conf does't seems to work (Worker update fails)  (Read 5040 times)

slubitz

  • Newbie
  • *
  • Posts: 1
qbwrk.conf does't seems to work (Worker update fails)
« on: April 16, 2009, 01:39:51 PM »
Hi all,

I am evaluating Qube! at the moment and after the installation I recognised some Problems.......
For Example:
I have a very small qbwrk.conf file located in c:\
[GlobalSettings]
proxy_execution_mode=user
client_host_domain=mydomain

After I run: qbadmin worker --reconfig the configuration on the Worker is still the same.
Is there a reason why?

I tried also qbconfigfile c:\qbwrk.conf.The output seems to be OK.

I can set the Values manually on each Client, but this is boaring :-)

Systemdata:
Supervisor: W2k8,64bit, 192.168.103.205
Clients: XP,64bit, 192.168.103.xxx

Has someone made the same experience?

Regards,
Stefan

Scot Brew

  • Hero Member
  • *****
  • Posts: 272
    • PipelineFX
Re: qbwrk.conf does't seems to work (Worker update fails)
« Reply #1 on: April 16, 2009, 10:46:45 PM »
It looks like you do not have the file placed in the right location.  On Windows, the qbwrk.conf file needs to go into the C:\WINDOWS directory (and will be next to the qb.conf file).  On Linux and OSX, the location is /etc/qbwrk.conf.

Here are 2 useful tools for working with the central worker configuration.  (the Linux/OSX path to qbwrk.conf is shown in the examples below):
  • sbin/qbconfigfile /etc/qbwrk.conf :  Show the expanded variables for the workers.
  • sbin/qbadmin worker --reconfigure : Pushes out a changed qbwrk.conf file for workers already running.  This can take a few minutes for large farms.
  • sbin/qbadmin worker --configuration <hostname> : Displays the configuration of the specified worker.

The workerlog may also provide some debugging information if the configuration is not being picked up:
? Linux/Mac OS X ? /var/log/workerlog
? Windows ? C:\Program Files\qube\logs\workerlog

See the Administration pdf manual Chapter 3 for more information on the qbwrk.conf topic.

jbravado

  • Newbie
  • *
  • Posts: 1
Re: qbwrk.conf does't seems to work (Worker update fails)
« Reply #2 on: June 09, 2009, 06:33:29 PM »
Hello everyone, despite following the examples and browsing the documentation pretty thoroughly, I'm still having trouble getting my workers to update from a global config file. I am doing a very very simple qbwrk.conf file, only attempting to add a group to a few of my workers. After doing qbadmin worker --reconfigure I get no errors. Looking at a workers log file I see that it receives the update request but nothing changes. Any thoughts?

Yantor

  • Full Member
  • ***
  • Posts: 18
Re: qbwrk.conf does't seems to work (Worker update fails)
« Reply #3 on: July 07, 2009, 10:58:36 PM »
I'll bump this thread with a similar and equally infuriating problem.

I am attempting to set up a rudimentary qbwrk.conf file on our supervisor system, a virtual server. The file currently has this in it;

[805a[01-15]]
worker_groups = "DAC"

[805b[01-15]]
worker_groups = "DAC"

Which in theory should assign our two labs to the same group, DAC. After saving this file I ran qbadmin w -reconfigure on the supervisor and absolutely nothing happened. I have tried restarting the supervisor and worker services, and looked extensively through the qb.conf files on both worker and supervisor for a clue as to why this refuses to update and reassign the workers to groups. Can anybody point me in the right direction?