Author Topic: linux qube 6.3.1 supervisor . . . Access denied for user 'pfx_dw'@'localhost'  (Read 4127 times)

westernx

  • Hero Member
  • *****
  • Posts: 55
Hello,

Just setting up our fedora 8 qube supervisor, and am seeing there is no access for the pfx_dw user to localhost. I am getting the following error repeatedly in /var/spool/mail/root ;

ERROR 1045 (28000): Access denied for user 'pfx_dw'@'localhost' (using password: NO)

I've setup my default mysql user as root, and set that in the qb.conf.  Are there some parameter options, to add to the qb.conf file to allow pfx_dw@localhost on my mysql server?

Thanks . . .

Ryjguy7

michael.graf

  • Sr. Member
  • ****
  • Posts: 26
did you have your mysql database secured before installing the sup? hence a password for the root user.

You should have noticed errors during the install of the sup rpm when the install_datawarehouse_db.sh started.

It was recommended to reset the root password to null and reinstall the sup.
Don't forget to comment out the database info in the qb.conf if this was already set.

jburk

  • Administrator
  • *****
  • Posts: 493
It would seem that somehow the permissions for the pfx_dw user got modified.

Can you tell me the output from the following 2 command run at the mysql prompt?

mysql> SELECT user,host FROM mysql.user;

mysql> SHOW GRANTS FOR pfx_dw@localhost;


Post the results back here and I should be able to tell you what's missing.

westernx

  • Hero Member
  • *****
  • Posts: 55
Code: [Select]
mysql> select user,host from mysql.user;
+---------------+-------------------+
| user          | host                      |
+---------------+-------------------+
| qube_readonly | %                    |
| root          | 127.0.0.1                |
| root          | localhost                 |
| root          | qbsupe02.keystone |
+---------------+-------------------+
4 rows in set (0.00 sec)

Code: [Select]
mysql> show grants for pfx_dw@localhost;
ERROR 1141 (42000): There is no such grant defined for user 'pfx_dw' on host 'localhost'

westernx

  • Hero Member
  • *****
  • Posts: 55
I also have this in my supervisor qb.conf ;


database_user = root
database_password = ********

westernx

  • Hero Member
  • *****
  • Posts: 55
o.k so I removed the supervisor and the mysql server,
and removed 

database_user = root
database_password = ********

from the qb.conf file, and reinstalled the mysql server and supervisor.
It's all working now

Thanks,

ryjguy7