Author Topic: Issue when submit a 3dsmax job to the render  (Read 6816 times)


  • Jr. Member
  • **
  • Posts: 3
Issue when submit a 3dsmax job to the render
« on: September 07, 2013, 09:16:57 AM »
Hello Everyone,

Currently i am testing this software if it will suit our needs but i got into a problem from the start. I installed and configured Qube, but when submiting a 3dsmax job the render job starts in green saying "running" but actually nothing happens, the CPU utilizes around 50% and stays that way. When i checked the logs i found that it has something to do with 3dsmax PID, but i don't know how to fix that. Here is the error that i get (this is the long output from the Log file of Qube):

INFO: checking 3dsmax executable [C:/Program Files/Autodesk/3ds Max 2013/3dsmaxcmd.exe]
INFO: doing DBR[vray]
INFO: scenefile [D:/Downloads/testrend/boxing gloves/boxing_glove+studio.max] exists and is readable
INFO: checking MaxManaged.xaml file(s) for corruption...
INFO: vray DR enabled-- doing distributed rendering
INFO: I am the DR master (client) node
INFO: slaves=[]
INFO: writing render host list to temp file [C:\Users\QUBEPR~1\AppData\Local\Temp\vray_dr-258.0-6ZvwAP.cfg]
INFO: created temporary vray_dr.cfg file:
INFO: copying scenefile [D:/Downloads/testrend/boxing gloves/boxing_glove+studio.max] to [D:/Downloads/testrend/boxing gloves/boxing_glove+studio.max-258.0.max]
INFO: 3dsmax executable explicitly specified
INFO: Using 3dsmax command line renderer [C:/Program Files/Autodesk/3ds Max 2013/3dsmaxcmd.exe]
INFO: using maxlogfile[C:\Users\QUBEPR~1\AppData\Local\Temp/qube-3dsmax-4404.LOG]
INFO: using named pipe[qube-3dsmax-4404]
INFO: copying blank scene file [c:/Program Files/pfx/jobtypes/_3dsmax/blank.max] to [C:\Users\QUBEPR~1\AppData\Local\Temp/blank-4404.max]
INFO: using executable file [C:/Program Files/Autodesk/3ds Max 2013/3dsmaxcmd.exe]
INFO: launching command [3dsmaxcmd.exe -PostRenderScript "c:/Program Files/pfx/jobtypes/_3dsmax/" -start 1 -end 1 -v 5 "C:\Users\QUBEPR~1\AppData\Local\Temp/blank-4404.max"]
INFO: spawned child process[PID=6744] for 3dsmaxcmd.exe
INFO: sleeping 3 seconds to allow 3dsmaxcmd.exe to launch 3dsmax.exe
INFO: parent process[PID=4404] searching for 3dsmax.exe PID that was launched by 3dsmaxcmd.exe[PID=6744])
INFO: waiting for 3dsmaxcmd.exe to exit [PID=6744]
INFO: 3dsmaxcmd.exe exited
ERROR: cannot find 3dsmax.exe PID at c:\Program Files\pfx\jobtypes/_3dsmax/ line 126.
INFO: cleaning up temp blank scenefile[C:\Users\QUBEPR~1\AppData\Local\Temp/blank-4404.max]
INFO: connected to 3dsmax pipe[qube-3dsmax-4404]
INFO: sending cmd[maxVersion()] to server pipe
INFO: reading from pipe

Accroding to this there is an error on line 126 of file The problem is that i am not familar with that scripting language and can't tell what exactly causes this. I can provide the file script if necessry so  you can see inside but i quess the support guys here are allready familiar with it.
Can someone suggest a fix of this problem because nothing seems to work? Also no information can be found on internet.


  • Jr. Member
  • **
  • Posts: 3
Issue when submit a 3dsmax job to the render
« Reply #1 on: September 09, 2013, 10:53:47 AM »
Still can't get around this. It seems the job starts and stays in status running but the frames stay in status pending and nothing happens. The CPU utilization is around 50%  but nothing is being rendered. We fixed the account permissions, share access and everything but still doesn't work.
Any ideas are highly appreciated.

Forgot to mention that Max was reinstalled from clean installation but it seems this doesn't help. We have tested this on another machine and it runs there and the log file shows that the script is able to find the PID and then everything works. So the question is here what could be the reason that it can't find PID for 3dsmax.exe on this machine (we have installed the same software and the same Max from the same installation).
« Last Edit: September 09, 2013, 02:47:25 PM by Bst »


  • Administrator
  • *****
  • Posts: 493
Re: Issue when submit a 3dsmax job to the render
« Reply #2 on: September 09, 2013, 10:23:17 PM »
As an eval customer, you're entitled to submit tickets to our Helpdesk.

Please send mail to, which will automatically create your account in our helpdesk and also submit your mail as a support issue.  You will then receive an account activation email; until you respond and activate your account your ticket will sit in a "suspended" state, but as soon as your account is active your ticket will move into our support queue and be picked up by the next available agent.

But, while you do that, you might also try submitting your render without the Distributed Bucket Rendering (DBR) enabled.  Just submit the simplest possible scene to test that Qube and Max are getting along, maybe 1 camera, 1 lambert sphere, 1 light, 2 frames.  If that renders, you know that Qube and Max are playing nice, and can start to layer on the complexity.

(this is the first thing that the support engineer will ask you to do anyways, so may as well get a head's start...)


  • Jr. Member
  • **
  • Posts: 3
Re: Issue when submit a 3dsmax job to the render
« Reply #3 on: September 10, 2013, 02:47:58 AM »
Thanks for the reply juburk. I thought that since i am using the trial to test out things i have not access to the help desk and support but it seems i wasn't right.
And about submiting the simplest possible scene, yes i have tried submiting without DBR i have allready tried it and i get the same error
But i will submit a ticket and see if the tech support guys can help me