Author Topic: Nuke(cmdline) job runs fine but Nuke(loadOnce) fails  (Read 845 times)

infinitesunrise

  • Jr. Member
  • **
  • Posts: 6
Nuke(cmdline) job runs fine but Nuke(loadOnce) fails
« on: April 06, 2016, 06:48:01 PM »
What the title says. I've attempted to render the same job both ways and the cmdline version finishes while the loadOnce seems to fail as soon as Nuke launches without any hint in the logs as to why. Do the two jobtypes use different types of Nuke licenses? The cmdline option opens Nuke with the -x flag and thus only uses a nuke_r (render-only) license. When I try a loadOnce job I see in my license server logs that the node checks out a nuke_r license as well, but then instantly returns it and the job fails. Is it looking for an additional interactive license, like nuke_i? I'd love to not have to re-load the Nuke scene every single frame like the cmdline jobtype does, but I only have nuke_r licenses for my farmers. Is this why loadOnce jobs are crashing?
« Last Edit: April 06, 2016, 06:49:38 PM by infinitesunrise »

BrianK

  • Hero Member
  • *****
  • Posts: 107
Re: Nuke(cmdline) job runs fine but Nuke(loadOnce) fails
« Reply #1 on: April 11, 2016, 05:07:08 PM »
You see the nuke license being returned so quickly simply because Nuke has closed.  Running Nuke in "load one" mode should not change the license used by Nuke while being run by Qube.

We would need to see job logs to see what's causing the failure.  This case would best be handled by regular support (by emailing support@pipelinefx.com).

In lieu of regular support, take a look at the job logs (visible through either GUI), and look for any error messages.  Feel free to copy/paste any error messages here.

-Brian