Author Topic: Linux Supervisor (FC5) / Windows XP Worker problem  (Read 3696 times)

ahujanen

  • Jr. Member
  • **
  • Posts: 3
Linux Supervisor (FC5) / Windows XP Worker problem
« on: October 02, 2007, 07:56:46 PM »
I'm a complete noob :) so I'm sure I'm missing the basics, but I've got a Linux Supervisor running and a Windows XP client. Everything seems to be operating on each end but the Worker log says:

ERROR: unable to establish tcp connection with 192.168.1.104 - unable to connect to host.

I've got the firewalls down on both systems. I'm running with all the install defaults, did I miss a port configuration some place?

eric

  • Hero Member
  • *****
  • Posts: 229
Re: Linux Supervisor (FC5) / Windows XP Worker problem
« Reply #1 on: October 02, 2007, 08:06:09 PM »
Have a look at the Getting Started chapter in the Installation manual. There's a step-by-step to make sure your Supervisor is ready to accept jobs.

ahujanen

  • Jr. Member
  • **
  • Posts: 3
Re: Linux Supervisor (FC5) / Windows XP Worker problem
« Reply #2 on: October 02, 2007, 08:41:38 PM »
I only see 2 processes running and qbping does not return anything. The log file seems fairly innocuous:

[Oct 1, 2007 14:00:37] bigbay : setting maximum bytes per communication to: 524288
[Oct 1, 2007 14:00:37] bigbay : time reference supervisor.
[Oct 1, 2007 14:00:38] bigbay : loaded worker config file: /etc/qbwrk.conf
[Oct 1, 2007 14:00:38] bigbay : using cluster/priority queuing algorithm
[Oct 1, 2007 14:00:38] bigbay : waiting for tcp socket to open up - port: 50002
[Oct 1, 2007 14:00:48] bigbay : waiting for tcp socket to open up - port: 50002
[Oct 1, 2007 14:00:58] bigbay : waiting for tcp socket to open up - port: 50002
[Oct 1, 2007 14:01:08] bigbay : waiting for tcp socket to open up - port: 50002
[Oct 1, 2007 14:01:18] bigbay : waiting for tcp socket to open up - port: 50002
[Oct 1, 2007 14:01:28] bigbay : waiting for tcp socket to open up - port: 50002
[Oct 1, 2007 14:01:38] bigbay : waiting for tcp socket to open up - port: 50002

Other suggestions?

eric

  • Hero Member
  • *****
  • Posts: 229
Re: Linux Supervisor (FC5) / Windows XP Worker problem
« Reply #3 on: October 03, 2007, 07:53:42 PM »
You should check for and then disable the hplip service, or you can change your supervisor port number.  However if you do this, every single client and worker will also need to reflect these settings (example):

supervisor_port = 10001
supervisor_sub_port = 10002
supervisor_http_port = 10000

I would look at disabling the hplip first, and see if that is sufficient to resolve the problem.

ahujanen

  • Jr. Member
  • **
  • Posts: 3
Re: Linux Supervisor (FC5) / Windows XP Worker problem
« Reply #4 on: October 04, 2007, 12:36:45 PM »
That did the trick! Thanks for the help