Author Topic: Snow Leopard and PERL  (Read 3520 times)

haich11

  • Sr. Member
  • ****
  • Posts: 32
Snow Leopard and PERL
« on: September 02, 2009, 02:14:42 PM »
I'm just testing Snow Leopard and the update seems to have broken Qube. Running 5.4-0 and has started throwing up this error when trying to run a test job:

Code: [Select]
ERROR: unsupported perl version 5.01000
Anybody else experienced this or know how to update PERL?

Scot Brew

  • Hero Member
  • *****
  • Posts: 272
    • PipelineFX
Re: Snow Leopard and PERL
« Reply #1 on: September 02, 2009, 06:11:09 PM »
Snow Leopard runs Perl 5.10.  Stay tuned -- we will look into providing a solution to address this.

michael.graf

  • Sr. Member
  • ****
  • Posts: 26
Re: Snow Leopard and PERL
« Reply #2 on: September 07, 2009, 11:40:34 AM »
hopefully this means windows and linux will finally get Perl 5.10 support??

Scot Brew

  • Hero Member
  • *****
  • Posts: 272
    • PipelineFX
Re: Snow Leopard and PERL
« Reply #3 on: October 01, 2009, 05:24:24 PM »
Windows should be getting Perl 5.10 support in the upcoming release. 

On Linux, the general philosophy to use the default version of perl and python still stands.  If that version of Linux uses perl 5.8 by default, that is the one that Qube will support.

Scot Brew

  • Hero Member
  • *****
  • Posts: 272
    • PipelineFX
Re: Snow Leopard and PERL
« Reply #4 on: November 04, 2009, 07:40:44 PM »
The Qube 5.5 release has Perl 5.10 support for Windows.  There are also new rpm installers for platforms like Fedora 8 64-bit, RHEL 5.3 64-bit, and OpenSuSE 11.1 with Qube using the perl and python versions that come native with those versions.