Author Topic: OSX Snow Leopard update for Qube: Recommend staying with Leopard at this time  (Read 5035 times)

Scot Brew

  • Hero Member
  • *****
  • Posts: 272
    • PipelineFX
Update: OSX 10.6 Snow Leopard now supported with Qube 5.5.2 and later.

Snow Leopard is out and now being distributed.  We have done some testing with Qube and also looked into the 3D application support.  What we have found indicates that though Snow Leopard may run fine under certain situations, it does have issues and holding off on updating for now would be a good policy.

Recommendation: PipelineFX recommends to stay with Leopard for now with Qube and 2D/3D Applications.

There is a lot of under-the-covers work for 64-bit that was introduced with Snow Leopard that has made it difficult for some apps.  Direct functional benefits seem fairly minor, though they do not seem to outweigh the potential pains.  From the production point of view, now is not the time for studios to risk delays or possible incompatibilities.  

Qube is not currently supported with Snow Leopard. until some of the issues are ironed out across the board.  PipelineFX will add support for Snow Leopard in the future, but now is not the time


Some 2D/3D/Database Application issues with Snow Leopard
Maya will not run on Snow Leopard at all and no indication from Autodesk is given as to a timeframe for a fix.

From Autodesk: "Maya 2010 will not work on Mac 10.6 (Snow Leopard)"
http://usa.autodesk.com/adsk/servlet/ps/dl/item?siteID=123112&id=13830094&linkID=9242258&CMP=OTC-RSSSUP01

The mysql daemon (used by the Supervisor) may need some more testing before it is ready as well, though it looks like some people have gotten it running with various levels of success.


Running Qube on Snow Leopard:
So you want to run it anyway?  Even though it is not supported at this time and at least some of the main 3D apps will not run on it?  And it is untested? Okay.  Here's some tips for you.

You may be able to run Qube by setting the default version of python and perl to use python 2.5 and perl 5.8.  This is not fully tested.  See "man perl" and "man python" for information on how to use the 32-bit perl 5.8 and 32-bit python 2.5 as the default versions.

UPDATE: To change the default versions of python and perl on Snow Leopard, you can use the 'default's command.  Both of the versions selected will be 32-bit

defaults write com.apple.versioner.python Version 2.5
defaults write com.apple.versioner.perl Version 5.8.9


We have also gotten the compiled QubeGUI to run and also the python interpreted one to run as well (using "python2.5 qube.py").


« Last Edit: April 29, 2010, 05:41:48 PM by Scot Brew »

Scot Brew

  • Hero Member
  • *****
  • Posts: 272
    • PipelineFX
We have done some initial testing of Qube on Snow Leopard.  Qube 5.4 and later should run on Snow Leopard, though there are some caveats.  Here is what we have noted so far.

  • Maya not qualified on Snow Leopard and will not run on it (as noted on the Autodesk forums and site)
  • Default Perl is 5.10 64-bit -- default perl needs to be switched to perl 5.8.9 (32-bit) if used by the jobtypes on the Worker.  See "man perl" as to how to switch it.
  • Default Python is 2.6 64-bit -- default python needs to be switched to python 2.5 (32-bit) if used by the jobtypes on the Worker.  See "man python" as to how to switch it.
  • QubeGUI -- must run compiled QubeGUI with Python 2.5 as Python 2.6 64-bit cannot run wxPython that the QubeGUI requires (ie. python2.5 qube.py)

As a result of these caveats, PipelineFX is not qualifying Qube for Snow Leopard at this time.  We would recommend staying with Leopard for production work. However if anyone tries it out and finds other issues or has other observations, please add to this thread.

dmeyer

  • Sr. Member
  • ****
  • Posts: 40
Hello Scot,

Any update on 10.6 support?  I am speccing a new installation here and intend to run Supervisor on a dedicated Xserve. I'd like to also run the file sharing for the farm on this machine as well  and thus would prefer to deploy 10.6 if at all practical.

We've also long been running Maya 2010 on Snow Leopard.  The issues around the web about it are relating to the licensing system being buggy, not Maya.  Runs great if you are floating your licenses.

Thanks

dball

  • Full Member
  • ***
  • Posts: 13
We really could do with 10.6 support here. We have 10 new 8 core machines arriving this week which can only run OS X 10.6.
Maya now officially supports 10.6 so any info on when Qube will.

I'm aware of the possibility of down grading the required libraries to 32bit but would rather not, especially if Qube will be updated in the very near future.

Scot Brew

  • Hero Member
  • *****
  • Posts: 272
    • PipelineFX
OSX 10.6 (Snow Leopard) now supported.
« Reply #4 on: April 29, 2010, 05:39:12 PM »
OSX 10.6 (Snow Leopard) supported with Qube 5.5.2 and later.  The installs are available to download from our ftp site.

See the announcement at:
    http://www.pipelinefx.com/forum/index.php?topic=843.0