Author Topic: Host status rejected  (Read 3790 times)

gratchie

  • Newbie
  • *
  • Posts: 1
Host status rejected
« on: August 03, 2010, 04:15:38 PM »
Hi,

I'm having problems adding new clients to our existing qube cluster.  The supervisor is complaining about 'host status rejected (restricted)' when detecting the new clients. Any ideas how we could fix this?


servername : query for host locks: clienthostname
servername : WARNING: host status rejected (restricted): 172.16.104.5 host.processors=0/8,host.memory=67/16039,host.swap=0/3814
servername : WARNING: received heartbeat from unknown host: 172.16.104.5 00:15:17:63:D4:A8


thanks,

jburk

  • Administrator
  • *****
  • Posts: 479
Re: Host status rejected
« Reply #1 on: August 03, 2010, 05:16:12 PM »
Check the supervisor_host_policy in the supervisor's qb.conf; if you do indeed want it to be restricted_by_address or restricted_by_name (the most common setting, and tolerant of DHCP), then you'll need to explicitly define the new workers.

When there is a supervisor_host_policy that is set to anything other than 'open', new workers need to be explicitly defined in the qbwrk.conf file on the supervisor.

If you add the entry into the qbwrk.conf ~after~ you start up the worker and it gets rejected, simply restart the worker service on the host in question and it will then successfully join the farm.

dmeyer

  • Sr. Member
  • ****
  • Posts: 40
Re: Host status rejected
« Reply #2 on: July 02, 2012, 09:03:53 PM »
I am seeing this error too.  Supervisor_host_Policy is set to open.

EDIT:  nevermind, had to re-clear the banned list a couple times. 
« Last Edit: July 02, 2012, 09:25:17 PM by dmeyer »