Author Topic: Cannot remove dead jobs from 5.2 GUI  (Read 4231 times)

jbrandibas

  • Sr. Member
  • ****
  • Posts: 35
Cannot remove dead jobs from 5.2 GUI
« on: August 31, 2007, 06:17:30 PM »
I have a large number of old jobs showing in the GUI.  If I try and remove them, I get the error "Failed to remove the following jobs: [xxx]"

It gives me no other info than that.  Is there a way to remove these dead jobs?

Scot Brew

  • Hero Member
  • *****
  • Posts: 272
    • PipelineFX
Re: Cannot remove dead jobs from 5.2 GUI
« Reply #1 on: August 31, 2007, 07:45:18 PM »
It is likely that this is not a GUI issue, but a Qube permissions issue.  You are likely not authorized to remove jobs, or at least those jobs, especially if they belong to someone else.  By default, you need to be a Qube administrator to remove jobs owned by other people. 

One thing you can try here to narrow this down is to submit a test job, kill it, and then remove it.

jesse

  • Sr. Member
  • ****
  • Posts: 40
Re: Cannot remove dead jobs from 5.2 GUI
« Reply #2 on: November 29, 2007, 10:40:02 PM »
I am having the same issue.  I understand that permissions need to be set.  I've tried on the supervisor to run /usr/local/pfx/qube/sbin/qbusers --add --remove USERNAME .  It did not seem to help even with a server restart.  The docs also mention the possibility of altering the global configuration to allow removal of jobs.  I could not find more information about this, nor were there any commented out example lines in the /etc/qb.conf file.

How can I enable the remove feature from the command line?

Thanks in advance.
-jesse

oh yeah I should show you my current users.  "3d" is the user in question and the remove permissions appears to be enabled.  The gui always reports a failure when trying to remove a job.

Code: [Select]
# /usr/local/pfx/qube/sbin/qbusers --list
total 5
---l jc- krmpbuicseyqg-vft      [default]
---- jcg krmpbuicseyqgpvft      3d
asil jcg krmpbuicseyqgpvft      Administrator
asil jcg krmpbuicseyqgpvft      qube
asil jcg krmpbuicseyqgpvft      root
asil jcg krmpbuicseyqgpvft      system
« Last Edit: November 29, 2007, 11:16:07 PM by jesse »

Scot Brew

  • Hero Member
  • *****
  • Posts: 272
    • PipelineFX
Re: Cannot remove dead jobs from 5.2 GUI
« Reply #3 on: December 31, 2007, 05:18:23 PM »
Hi Jesse,
I will redirect your question to our expert with the Qube core and permissions to get this straightened out for you.
Regards,
Scot

anthony

  • Senior Software Engineer
  • Hero Member
  • *****
  • Posts: 183
Re: Cannot remove dead jobs from 5.2 GUI
« Reply #4 on: January 02, 2008, 08:24:18 PM »
Hey Jesse,

    Typically, permissions for job removal are restricted to the user whom owns the jobs.  This behaviour can be changed if you add them as an administrator, or setup the default permissions on your server to make everyone an admin.   To check which user Qube! sees you logged in as, try the following:

    Start->Run  type: cmd
    cd C:\Program Files\pfx\qube\bin
    qblogin
    (Note: type anything in for the password, just make sure they don't match, so that the tool doesn't update the supervisor)

    If your environment requires you to create an Administrator, then the command you want to use is this:

    qbusers --add --admin --all <username>

    If your environment doesn't enforce network security, and you want mutual control of your farm between all users, then you can also setup your supervisor to consider everyone an admin.

    Goto the Start->Programs->PipelineFX->Qube->Configuration

    Select the Supervisor Tab, and look for the Default Security settings.  Check on "Administrator" and allow the daemon to be restarted.

     Please note that all of the instructions have been written for Windows environments. 

     Thanks,
          Anthony