Author Topic: XSI 6.5 64bit Jobtype problems  (Read 5911 times)

cyborg

  • Jr. Member
  • **
  • Posts: 5
XSI 6.5 64bit Jobtype problems
« on: June 17, 2008, 04:52:07 AM »
XSI jobtype menu cannot be launched on 64bit version of XSI6.5. And we found that the 'QubeSubmit.py' file is already installed in C:\Softimage\XSI_6.5_x64\Application\Plugins folder.
And the 32bit version Jobtype is running excellent.

Regards,
Tim
« Last Edit: June 17, 2008, 04:59:39 AM by cyborg »

eric

  • Hero Member
  • *****
  • Posts: 229
Re: XSI 6.5 64bit Jobtype problems
« Reply #1 on: June 17, 2008, 05:31:26 AM »
Which version of the Job Type are you running?

cyborg

  • Jr. Member
  • **
  • Posts: 5
Re: XSI 6.5 64bit Jobtype problems
« Reply #2 on: June 17, 2008, 07:28:40 AM »
It should be version 5.3 which downloaded from FTP area. And the file name is "qube-xsijt.msi".

jason.fowler

  • Guest
Re: XSI 6.5 64bit Jobtype problems
« Reply #3 on: June 21, 2008, 05:41:27 AM »
Hi Tim,

We're taking a look at this problem now - we think it might be a python issue with regard to the 32/64 bit paths.  Sorry for any hassles this may have caused, and thanks for bringing this to our attention.  Someone will get back to you soon.

-Jason
PipelineFX

Scot Brew

  • Hero Member
  • *****
  • Posts: 272
    • PipelineFX
Re: XSI 6.5 64bit Jobtype problems
« Reply #4 on: July 15, 2008, 06:13:50 PM »
It has been confirmed that XSI 6.5 does work with XP 64bit.

There is likely something in your environment that needs to be adjusted. We will follow up with you directly to track down the issue you are experiencing.

Regards,
Scot

curly

  • Jr. Member
  • **
  • Posts: 8
Re: XSI 6.5 64bit Jobtype problems
« Reply #5 on: July 21, 2008, 07:43:27 AM »
Could you let us know what are the proper environment settings and where to enter these settings in order to get it work? We asked Softimage and they said it is qube issue. We are just not sure if we have to set any environment in Windows or any preference files in Softimage in order to get it work. Thanks.

Scot Brew

  • Hero Member
  • *****
  • Posts: 272
    • PipelineFX
Re: XSI 6.5 64bit Jobtype problems
« Reply #6 on: August 28, 2008, 09:20:41 PM »
Could you let us know what are the proper environment settings and where to enter these settings in order to get it work? We asked Softimage and they said it is qube issue. We are just not sure if we have to set any environment in Windows or any preference files in Softimage in order to get it work. Thanks.

For the XSI BatchRender simplecmd jobtype, here are the main requirements:
  • pointing to the correct executable when submitting the job
  • making sure that the license server can be seen.  This may require explicitly setting the SPM_HOST environment variable.  To do so directly in the submitting command, one can insert the "set" command before rendering as shown here: set SPM_HOST=<yourLicenseServer> && "%(xsiExe)s" ...


For the XSI python jobtype with dynamic allocation, here is the README describing the installation and setup.
Code: [Select]
###########################################################################
#
# Copyright (c) PipelineFX L.L.C. All rights reserved.
#
###########################################################################
#
# Filename: README.txt
#
# Description:
#
#  This is the README file for the XSI jobtype for Qube!
#  It contains the latest information about this package.
#
###########################################################################

[SUPPORTED XSI VERSIONS]

XSI 5.x, 6.x, or above.

As of the xsi jobtype version 5.3-0, we have dropped support for XSI
versions 4.x and below-- XSI 5.x and above should work.

64-bit versions of XSI is only supported for XSI 6.x and above.


[REQUIREMENTS]

* XSI 5.x, 6.x, or above.

* Qube version 5.3-x or above.

* Python for XSI 6.x and above.

  For XSI 6.x and above, you need the Python language installed and
  properly working.  On Linux, Python should be automatically
  installed for you.  On Windows, you'll need to perform some extra
  steps (on all clients and workers).

  Please also refer to:

  http://softimage.wiki.avid.com/index.php/Python


  [32-bit Windows and Python]

  Please refer to the section entitled "To install Python on Windows"
  in the XSI documentation for more details:

  * "Start" Menu -> "All Programs" -> "Softimage Products" ->
      "Softimage XSI <ver>" -> "Documentation" -> "XSI Guides"

  * Goto the "Contents" tab, then
      "Customization" -> "Scripts" -> "Scripting Languages"

  * Scroll down to the section on "Python ActiveX Scripting", and
    follow the instructions on "To install Python on Windows"


  [64-bit Windows and Python]

  As of this writing, you must install ActivePython 2.4.3.12, AND a
  module called "pywin32", available from Softimage's "XSI 6.5
  Advanced Downloads" page, at the URL:

  http://softimage.com/downloads/XSI_Advanced/default.aspx

  Look for the "Python - 64-bit" link in the "Windows" section.

  <quote>
  Python - 64-bit:

  Extensions to run Python on the Windows 64-bit operating system. You
  must first install the Win64 Python version from www.ActiveState.com
  (ActivePython-2.4.3.12-win64-x64-nopywin32.msi). Will not work on a
  machine already running ActivePython for 32-bit.
  </quote>


[INSTALLATION NOTES]

After installing the Qube! XSI jobtype, you should see a top-level
"Qube!" menu on the menu bar.

If you have XSI installed in a non-default location, you will need to
open the plug-in manager and load the Qube plugin manually.  For 6.x
and above, this is the file "Qube.py"; for 5.x it is "qb.dll"
(Windows) or "qb.so" (Linux).

* "File" Menu -> "Plug-in Manager..."

* Click the "Load..." button, and navigate to the location where
  XSI jobtype is installed.  This is usually:

    C:\Program Files\pfx\jobtypes\xsi

  Select the Qube.py (qb.dll/qb.so for XSI 5.x) file, and hit "OK".

Alternatively, you can copy the plugin file (Qube.py, qb.dll or qb.so)
to the "Application/Plugins/" folder of your XSI installation folder
for the Qube plugin to automatically load when you start XSI.


[KNOWN ISSUES]

* (XSI 5.x) Some of the Output tab parameters won't apply to the All
  Passes choice or to multiple passes. For single pass rendering, the
  back-end will respect the output image file path (and certain other
  parameters) specified in the submission dialog. When rendering "All
  Passes" or multiple passes, each pass will use its specified output
  image path as defined in the scene. (Case 22528) Note that the frame
  range in the GUI does apply for a single pass or multiple passes.


* (XSI 5.x) A qbXsiSubmit error will show when opening a scene saved
  after showing the Qube submission dialog. This will happen if XSI
  has been launched, but the Qube submission dialog hasn't been shown
  yet. The error message is harmless. (Case 22585)


* In Windows under proxy execution mode, if you have installed XSI in
  a non-standard location, and Qube jobs seem to be having problems
  finding the xsibatch.bat command to render, it is likely that the
  proxy user does not have read-access to the windows registry to find
  out where the xsibatch.bat command is installed.  If that is the
  case, you can give the proper privileges to the qubeproxy user to
  gain access to that registry value.  Alternatively, use one of the
  following methods to tell the worker to look for XSI installed in
  non-standard locations:

  - make sure the PATH environment variable of the execution
  environment includes the custom location

  - modify the "default_xsi_locations_MSWin32" parameter in job.conf

shinya

  • Administrator
  • *****
  • Posts: 229
Re: XSI 6.5 64bit Jobtype problems
« Reply #7 on: November 13, 2008, 11:09:32 PM »
Hi ok0523,

What particular problems are you having?  Any error message that you're seeing?